解决MacBook使用brew无法安装PHP5.6问题Error: php@5.6: Invalid bottle tag symbol

7天前   阅读:150   分类:后端    标签: PHP

Mac os 1.14 系统之后,如果想安装php5.6版本的时候,无法用brew install php5.6安装,因为在新的brew中已经废弃了php5.6和php7.0,如果使用brew search php搜索出来的Php版本最低是php@7.1的

一、网上搜到的解决方案:

1、添加源

brew tap exolnet/homebrew-deprecated 

2、搜索

php brew search php 

3、安装

php brew install php@5.6

结果还是无法解决,出现问题:Error: php@5.6: Invalid bottle tag symbol

后面找到另一种方法:添加其他下载源

二、有效的解决方案

1、终端执行

brew tap shivammathur/php

2、搜索

brew search php

可以看到包含很多PHP版本

3、执行安装

brew install shivammathur/php/php@5.6

4、成功安装

【腾讯云】2核2G云服务器新老同享99元/年续费同价,8888元代金券限时抢

‘简忆博客’微信公众号 扫码关注‘简忆博客’微信公众号,获取最新文章动态
转载:请说明文章出处“来源简忆博客”。http://tpxhm.com/adetail/1059.html

×
觉得文章有用就打赏一下文章作者
微信扫一扫打赏 微信扫一扫打赏
支付宝扫一扫打赏 支付宝扫一扫打赏

文章评论(0)

登录
简忆博客壁纸一
简忆博客壁纸二
简忆博客壁纸三
简忆博客壁纸四
简忆博客壁纸五
简忆博客壁纸六
简忆博客壁纸七
简忆博客壁纸八
头像

简忆博客
勤于学习,乐于分享

置顶推荐

打赏本站

如果你觉得本站很棒,可以通过扫码支付打赏哦!
微信扫码:你说多少就多少~
微信扫码
支付宝扫码:你说多少就多少~
支付宝扫码
×